Strange inability to delete files in CGI-BIN....

Information and hep with Lil HTTP Server
Post Reply

Strange inability to delete files in CGI-BIN....

Post by jfdutcher »

I placed an .exe file in the CGI-BIN for LilHTTP. (Win XP).
An attempt to execute from the browser was made.
It produced a blank return page....not an issue
BUT I tried, subsequently to simply delete the .exe
from the CGI-BIN with Windows Explorer.
There would be a couple second delay and then an error dialog box
would open saying that either the disk was full or read only,
(neither is the case). I shut down the LilHTTP server and tried again...
same result...still wouldn't allow me to delete.
I shut down Internet Explorer (used to retreive the .exe) and tried
again to delete the .exe,..same result as above.
Finallly I shut down and re-booted the PC.....then I could delete
the .exe from the CGI-BIN. There were actually (3) newly created
.TMP files in CGI-BIN throughout the above ....they were also
'undeletable' until the re-boot. Basically, I'm just trying to understand
how this could be ???
User avatar
Site Admin
Site Admin
Posts: 2557
Joined: Wed Apr 16, 2003 5:35 pm
Location: Western PA

Post by Scott »

Sounds like Windows thought that the files were "in use". I have had Windows do this with other files (not related to Lil HTTP) before. This is usually a rare occurance. I found that it happened after the OS was running for 5 or 6 days straight without a reboot (Win XP Pro). Lil HTTP only opens the files temporarily to execute them (via Windows API) and then returns them to their original state. I don't know what could cause this. Are you logged in as an Administrator user? Lil HTTP should have FULL rights to all of its directories.

The temp files are more than likely I/O pipes for the CGI file, 1 for Input, 1 for Output, and one for Errors.

Post Reply