running under Linux

General Information about POS Pizza 8
Post Reply
H-Man
Veteran Member
Veteran Member
Posts: 197
Joined: Fri Apr 18, 2003 12:50 pm
Location: New Jersey

running under Linux

Post by H-Man »

I have been experimenting running pos pizza under Linux using both wine, and virtualbox. Both work very well, but virtualbox has a bit more overhead. Wine runs the pos very quickly, and so far without issue. The only thing that I noticed was that some of the windows don't draw correctly but the system is still perfectly usable.

One of my next tests will be to run the pos on a raspberry pi. There's an arm version of windows 10, that a group has been able to run on the pi, so I am going to see if the pos will run on that.
User avatar
Scott
Site Admin
Site Admin
Posts: 2502
Joined: Wed Apr 16, 2003 5:35 pm
Location: Western PA

Re: running under Linux

Post by Scott »

I will be interested to hear how the ARM version of Windows 10 works out for you.


Scott
H-Man
Veteran Member
Veteran Member
Posts: 197
Joined: Fri Apr 18, 2003 12:50 pm
Location: New Jersey

Re: running under Linux

Post by H-Man »

I tried both windows 10 and 11 on the ARM and the pos ran, but it wouldn't open the payment window. It gives the following error: "Invalid Call" / "Error Initializing Payment".

I understand that this is an unsupported cpu architecture, but it was still cool to play with.
User avatar
Scott
Site Admin
Site Admin
Posts: 2502
Joined: Wed Apr 16, 2003 5:35 pm
Location: Western PA

Re: running under Linux

Post by Scott »

H-Man wrote: Mon Oct 10, 2022 5:39 pm "Invalid Call" / "Error Initializing Payment"
If you still have that system setup, go into the CS folder and locate the file named CheckRqdComp.exe, and double-click it to launch it. It should show whether or not the required components were properly registered with Windows. I suspect that the payment services module did not register for whatever reason. I don't know much about Windows ARM, so can't really say why things may not register.


Scott
H-Man
Veteran Member
Veteran Member
Posts: 197
Joined: Fri Apr 18, 2003 12:50 pm
Location: New Jersey

Re: running under Linux

Post by H-Man »

You are right, the payment service isn't registered. Tried re-installing, but it still didn't register.

Running under wine however, is working great.
Post Reply