Config load error

Questions and Answers that relate to the [CS] Version of POS Pizza 6
Member
Posts: 22
Joined: Wed Jun 07, 2006 9:39 am
Location: UK

Config load error

Postby horndeanpizza » Mon Oct 24, 2016 5:28 am

Scott, Server running fine but order stations wont connect. Error - 406 = invalid cfg version. expected 7 received 0. happened mid order last night cannot get back in. Cannot find on forum help please. thankyou.

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Config load error

Postby Scott » Mon Oct 24, 2016 6:06 am

Your database file is likely corrupted. You will need to restore from a backup made prior to the problem occurring.


Scott

Member
Posts: 22
Joined: Wed Jun 07, 2006 9:39 am
Location: UK

Re: Config load error

Postby horndeanpizza » Mon Oct 24, 2016 6:18 am

Just tried that with 2 different backups no joy. Also tried updating client to 7. install uninstall server.

this is the code from yesterday.

161023163427 Admn Strt ==========<[ Start Server ]>==========
161023163429 Admn Flgs TrimLogManually=No
161023163429 Admn Flgs LogConnDcon=Yes
161023163429 Admn Flgs LogInvalidInMessage=No
161023163429 Admn Flgs CreateDatabaseAllowed=No
161023163429 Admn Data MaxChunkSize=500
161023163429 Admn Data ConnectionTimeout=30
161023163429 Admn FACT Non To Load
161023163429 Host LocalHost(127.0.0.1) Socket=592 Port=54181
161023163429 Host pos1(192.168.25.183) Socket=612 Port=54181
161023163429 Admn UDP Service Started
161023163524 Conn UDP Request processed
161023163524 Conn #7 SK 612 applePOS1192.168.25.183
161023163524 Conn UDP Request processed
161023163524 Conn #8 SK 612 applePOS1192.168.25.183
161023163734 Conn UDP Request processed
161023163734 Conn #12 SK 612 applePOS1192.168.25.183
161023170443 Conn UDP Request processed
161023170444 Conn #40 SK 612 HorndDESKTOP-54AF6PN192.168.25.216
161023195530 Conn UDP Request processed
161023195530 Conn #210 SK 612 applePOS1192.168.25.183
161023195554 Dcon #210 Dropped
161023201146 Conn UDP Request processed
161023201146 Conn #228 SK 612 applePOS1192.168.25.183
161023201210 Dcon #228 Dropped
161023211235 Dcon #12 Dropped
161023211237 Dcon #40 Dropped

This is from now. Dont know if it helps.

161024121100 Conn UDP Request processed
161024121100 Conn #7 SK 604 applePOS1192.168.25.183
161024121102 Dcon #7 Dropped

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Config load error

Postby Scott » Mon Oct 24, 2016 6:35 am

It sounds like the backup was made on a different machine or one with a different IP.

Use the following steps to restore your backup.

1. Stop the server & uninstall the server service from the admin tool
2. Restore the backup
3. Completely exit the admin tool
4. Go to C:\POSPizza6\Server and delete the file named "POSPizzaDBServer.Cfg" (make sure admin tool is *not* running when deleting!)
5. Run server admin tool.
6. Install service, and start server.


This should work for you.


Scott

Member
Posts: 22
Joined: Wed Jun 07, 2006 9:39 am
Location: UK

Re: Config load error

Postby horndeanpizza » Mon Oct 24, 2016 6:46 am

No sorry no joy. backup goes to usb stick in server computer always done it that way never had a problem. have old desktop computer running xp as server and order station one, then new tablet running windows 10 i think, order station 2. all connected via asus internet hub (dont know technical words). have turned of everything except server computer and internet. Would deleting everything and doing fresh install help.

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Config load error

Postby Scott » Mon Oct 24, 2016 6:49 am

Is your server not starting after restoring a backup? If that's the case deleting the .Cfg file should correct the issue.


Scott

Member
Posts: 22
Joined: Wed Jun 07, 2006 9:39 am
Location: UK

Re: Config load error

Postby horndeanpizza » Mon Oct 24, 2016 6:50 am

server is starting and seems to be running fine the error is coming when you click order station or driver console or managment.

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Config load error

Postby Scott » Mon Oct 24, 2016 6:54 am

So you're still seeing the corrupt backup file issue.

Try stopping the server, then move your existing POSPizza.PZ6 file up one level to the C:\POSPizza6 folder, and then restore a previous backup.

If all else fails you can zip up the POSPizza.PZ6 file and email it to me. I can see if I can recover some of the data. You will lose the employee data and the main config data, but the customers, menus, and transactions should be recoverable unless the file is in really bad shape.

Scott

Member
Posts: 22
Joined: Wed Jun 07, 2006 9:39 am
Location: UK

Re: Config load error

Postby horndeanpizza » Mon Oct 24, 2016 7:46 am

ok had a play with it. all now works but had to go back to back up from may 16. all back ups since are corrupted or empty. seems to be from when i updated to 6.90.03 all backups since update are bad. have still got pz6 file if you can try and recover what you can. where do i find your email address? thanks matt

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Config load error

Postby Scott » Mon Oct 24, 2016 7:56 am

I sent you my email address in a private message.


Scott

Return to CS Version Discussion

Who is online

Users browsing this forum: No registered users and 2 guests