Server Restart Issues

Questions and Answers that relate to the [CS] Version of POS Pizza 6
Veteran Member
User avatar
Posts: 244
Joined: Wed Oct 12, 2011 1:38 pm
Location: Pennsylvania

Server Restart Issues

Postby synpse » Sun Nov 23, 2014 1:24 pm

So, when Windows 7 installs updates and reboots, (or restarted, or turned on.. cold boot) The POS Pizza client link is set in the Startup Folder. BUT.. it gets the error "cannot connect to DB server". We have to use the admin util and START the server.

Same thing with the SMS service program. It cannot connect to the DB, and just fails. It retries once, 120 seconds later (or whatever it's set to).

Is there anything special to get it to startup, and auto-launch the client? This is on the main POS computer, which is also the server.

Everything is up to date, current version.


Sorry about the choppy wording, we have plumbing issues this sunday morning.. it's been.. toilet paper-ish yuck.

Site Admin
User avatar
Posts: 2083
Joined: Wed Apr 16, 2003 4:35 pm
Location: Western PA

Re: Server Restart Issues

Postby Scott » Mon Nov 24, 2014 8:12 am

The server will start when the system starts unless; 1) network address is not available during start attempt, 2) cable disconnected or does not have a steady link, or 3) dongle not present.

If you want to auto-start a client on the same computer as the server, then you will need to delay the start for 20-30 seconds so that the server can get up and running. Many times the server is running but the start of the Windows firewall, etc. interrupts the data between the two until the system stabilizes. Things like the CID server, and the SMS Dispatcher automatically "wait" for a period of time before attempting connection. You should be able to use a batch timer, or other similar util to delay the start on the client when used on the same machine as the server.

Clients located on PCs other than the server PC don't need any delay. They can attach immediately (provided that the server is running).


Scott

Veteran Member
User avatar
Posts: 244
Joined: Wed Oct 12, 2011 1:38 pm
Location: Pennsylvania

Re: Server Restart Issues

Postby synpse » Thu Apr 28, 2016 11:00 pm

Follow Up: Bad USB port on ELO Touchscreen. USB Key Dongle 'hidden' on USB ports in the touch screen. Shut that off.. and yea, the POS program gets upset.

Return to CS Version Discussion

Who is online

Users browsing this forum: No registered users and 2 guests